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5
Evaluate Inputs

Objectives

• Identify and organize potential inputs using a fishbone diagram

• Create a rating-vote ballot to prioritize process-improvement options

• Complete a C&E matrix by creating a ballot from a table
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Fishbone Diagrams
Example 1  Identify and organize potential inputs

The team wants to determine the potential causes of pizza 
defects. They create a fishbone diagram to assist their 
brainstorming efforts.

Tools

• Fishbone
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Creating a fishbone diagram 

The fishbone—also called a cause-and-effect diagram or an 
Ishikawa diagram—is one of 3 brainstorm diagrams that are 
available in Quality Companion. Use a fishbone diagram to 
perform brainstorming sessions about potential causes of an 
effect or problem. 

The team determines the potential causes that contribute to 
incorrect toppings on pizzas. The project leader conducts a 
brainstorming session with the project team and key 
stakeholders. Together, they create a fishbone diagram to 
organize this information.

Fishbones contain these elements:

• Effect, or problem

• Affinities are located on the spine of the central effect

• Causes and subcauses

Create a fishbone diagram

1 In the Project Manager, click Measure 4.

2 On the toolbar, Click , and then choose Fishbone. In 
the New dialog, choose Fishbone.

3 Click OK.

4 Click Effect and type Incorrect Toppings. 

5 Click an Affinity and type Wait staff. 

6 Click another Affinity and type Menu. 

7 Under the Wait staff affinity, click the cause and type 
Understand menu. 

8 Under the Menu affinity, click the cause and type Define 
toppings. 
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Adding affinities, causes, and sub-causes

A team member suggests that, in addition to the wait staff 
and the menu, the work station layout can affect whether the 
cooks prepare a pizza correctly.

To add affinities, causes, and sub-causes, choose an option:

• Double-click the workspace. Quality Companion adds a 
new affinity that you can drag to a new location.

• Right-click the shape and choose Insert ➤ Affinity or 
Insert ➤ Cause.

• On the brainstorm toolbar, click  to insert an affinity or 
click  to insert a cause.

Add affinities, causes, and sub-causes

1 Double-click the workspace to create a new affinity, and type 
Work station. 

2 Click the Work station affinity, then click  on the brainstorm 
toolbar to create a new cause. Type Labels.

3 Right-click the Labels cause and choose Insert ➤ Cause. 
Type English. Repeat to add another cause and label it 
Spanish.

4 Add 2 more affinities and label them Ingredients and Order 
system. 
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Using the brainstorm list

The brainstorm list provides a location to enter ideas that you 
can drag onto an idea map, fishbone diagram, or CT tree.

The team uses the brainstorm list to generate ideas without 
having to stop and determine the proper placement on the 
fishbone. After they generate a list, the team can drag the 
items from the brainstorm list to any level of the diagram.

Use the brainstorm list

1 Click Brainstorm List in the task pane.

2 Type Substitutions in the first empty field near the top of the 
pane. 

3 Press [Enter] to add the item to the list.

4 Repeat to enter the following items as shown. 
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Importing x and y variables

You can save time and effort by importing shared data, such 
as x and y variables, into the brainstorm list. 

Changes made to a variable in a brainstorm tool are not made 
to the variable in other areas of Quality Companion.

Import x and y variables

1 Right-click in the Brainstorm List and choose Import X 
Variables.

2 In the Data Selection dialog box, check Cheese, Meats, and 
Vegetables. 

3 Click OK.
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Laying out the diagram

Drag items from the brainstorm list to create your diagram. 
When you drag an item from the brainstorm list or from 
anywhere on the map, you see a preview of where the item 
will be placed. Once you determine the item’s new location, 
release the mouse button.

Lay out the diagram

1 In the brainstorm list for the fishbone diagram, click 
Substitutions and drag it to the Ingredients affinity. 

2 When you see the red preview, release the mouse button.

3 Use this method to create the following diagram. (Hold down 
[Ctrl] to select multiple items in the brainstorm list.)
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Making x and y variables

You can also select any shape in any brainstorm diagram and 
make it into an x or y variable. The variable is added to 
Process Map Data where it can be shared with other tools 
throughout Quality Companion. You can add and edit 
detailed information about each variable; however, these 
changes are not reflected on the brainstorm diagram. The text 
in the shape on the brainstorm diagram is the name for the 
variable in Process Map Data.

Make x and y variables

1 Press [Ctrl] and click the Menu and Ingredients shapes on 
the diagram. 

2 Right-click and choose Make X Variables. 

3 Click OK.

4 Double-click Process Map Data in the Project Manager. 
Notice that Menu and Ingredients appear as unmapped 
variables.
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Rearranging the layout

You can rearrange the layout of your diagram. When you 
move the affinities on a diagram, all causes and subcauses for 
the shape also move.

You can also change the side that an idea, cause, or affinity 
appears on a diagram.

Rearrange the layout

1 Double-click Fishbone in the Roadmap.

2 Right-click the Order System affinity and choose Switch 
Sides.

3 Drag the Menu affinity to the Order System affinity. Menu 
becomes a cause and Define our toppings becomes a 
subcause. 
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Adding comments and priorities

You can insert comments and priorities for any of the shapes 
on an idea map, fishbone diagram, or CT tree. When you add 
a comment or priority, the appropriate icon appears next to 
the shape. To read or edit the comment, double-click the 
comment icon to display it in the task pane.

The priority icon indicates the priority level. Each priority 
level has its own color icon. 

To show of hide comment or priority icons choose:

• View ➤ Icons ➤ Comments

• View ➤ Icons ➤ Priorities

Add comments and priorities

1 Right-click the Form layout cause and choose Insert ➤ 
Comments.

2 In the task pane, from Priority, choose 1 - Highest.

3 Type Comments as shown below. 

4 Click the workspace and note the icons next to shape. 

5 Pause your mouse over the comment icon to display 
comment text.

Icon Color Priority Level

Red Highest

Orange High

Yellow Medium

Blue Low

Green Lowest
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Formatting shapes and text

You can format shapes individually or as groups: 

• To select all of one type of shape, such as affinities, 
choose Actions ➤ Select ➤ Affinities.

• To select multiple shapes:

– Drag your mouse around a selection

– Click shapes while pressing [Shift] or [Ctrl]

• To copy and paste the format of a shape or text box and its 
font style to other shapes, use the Format Painter  
button on the toolbar.

Format shapes and text

1 Right-click the Incorrect Toppings effect and choose 
Format ➤ Text.

2 Increase the font size and click OK. 

3 Choose Actions ➤ Select ➤ Subcauses.

4 Choose Format ➤ Fill. 

5 Change the color and click OK.
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Changing the layout

In addition to fishbone diagrams, Quality Companion also 
provides 2 other brainstorm diagrams: idea maps and CT 
trees.

These brainstorm diagrams share similar features but differ 
slightly in their use, layout, and terminology: 

To change the layout of your current brainstorm diagram, 
you can convert it to another layout. You can also change 
shape parameters. 

Change the layout

1 Choose Format ➤ Layout. 

2 From Layout style, choose Tree.

3 From Direction, choose Center to Left/Right.

4 Click OK. Tool Common Use Terminology

Idea Map General purpose 
mind-mapping or 
brainstorming

Central Question, 
Affinity, Idea

Fishbone Cause/effect mappings Effect, Affinity, 
Cause

CT Tree Critical-to-quality 
mappings

Critical To, Affinity, 
Input
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Final considerations

Summary and conclusions

The team created a fishbone diagram using structured 
brainstorming to identify causes that could contribute to 
pizza defects.

Additional considerations

Collapse  or expand  affinities, causes, and subcauses to 
view specific levels of the fishbone diagram. You can also 
choose Actions ➤ Collapse ➤ Affinities or Causes. 

You can export a fishbone diagram, or any brainstorm 
diagram, to a new Microsoft Word document or PowerPoint 
presentation. Choose Actions ➤ Export to ➤ PowerPoint or 
Word, or use the export toolbar.

Use Pan Window, auto scroll, or zoom to navigate a large 
diagram.

Button Description

Export to PowerPoint

Export to Word

Button Description

Pan Window

Auto Scroll

Zoom
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Rating-Vote Ballot
Example 2  Evaluate the options

Problem

The team identifies 5 actions to reduce customer wait times. 
The project leader wants the whole team to have input into 
which action to pursue, but there is no time when everyone 
can meet. The leader creates a ballot so the team can vote as 
their schedules allow.

Tools

• Rating-vote ballot

Support files

17Ballots.qcp

18RatingVote.qcp
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Ballot – Overview

Quality Companion supports these voting methods:

• Multi-vote: Individuals select one or more candidates 
from a list. This can be done remotely and over a period 
of time.

• Group multi-vote: The group votes for one or more 
candidates in a single voting session. Votes are counted 
and entered by one person.

• Rating-vote: Individuals rate candidates on specific 
criteria, such as cost, time, acceptance, and so on. This 
can be done remotely and over a period of time.

When you open a new ballot, status icons appear in the ballot 
header. Because these icons represent sections of the ballot 
setup, they vary based on ballot type.  

You can click these icons to move through ballot setup.

When you complete a section successfully, a checkmark 
appears. If you do not provide all of the required information, 
however, an exclamation point appears. You cannot complete 
the ballot until you enter all of the required information.

Ballot Type Icons

Multi-vote

Group Multi-vote

Rating-vote

Icon Description

Section complete

Section incomplete
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Creating a ballot

The project leader chooses a rating-vote ballot to prioritize 
the 5 improvement options to reduce customer wait time.

Create a ballot

1 Open 17Ballots.qcp.

2 Right-click Analyze 1 in the Roadmap and choose New ➤ 
Ballot. 

3 Choose Ballot.

4 Click OK.

5 In Central issue, type Best option?.

6 Choose Rating-vote.

7 Click Next.
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Adding voters

On the voters page, add the names of those who will vote on 
the issue. Voters are not limited to team members. You can 
type a voter name in the input row or select a team member 
from the drop-down list.

You can also:

• Add all of your team members at once

• Allow team members to abstain from voting

• Use the up and down arrows to change the voting order, or 
delete a voter, if necessary

• Check Use anonymous voting to prevent voters (even the 
person setting up the ballot) from seeing individual voting 
results

The project leader decides not to include the staff in this vote 
and limits it to only project team members.

Add voters

1 Click  to add all of the team members. 

2 Click Next.
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Adding candidates

On the candidates page, type an item in the input row to add 
it to the list of items that team members will rate when they 
cast their votes.

You can also:

• Use the up and down arrows to change the order, or to 
delete a candidate from the list

• Add comments to a candidate to help voters understand 
the candidate

• Inform voters of the number of candidates that they can 
choose

When you set up a ballot, cast a ballot, or view the results of 
a vote, you can insert comments or edit existing comments 
about a candidate.

After you add a comment, the comment icon on the final 
ballot changes to indicate that a comment exists.

Add candidates 

1 Under Candidate, type Fix oven.

2 Press [Enter].

3 Add the remaining candidates as shown below.

4 Click Fix oven, and then click . 

5 In the task pane under Comments, type Need parts.

6 Click Next.

No comment

Comment
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Adding criteria

On the criteria page, add the criteria on which to rate 
candidates. Voters can rate criteria on a variety of scales. For 
example, from low to high, weak to strong, worst to best, and 
so on. When Quality Companion tabulates the results, it 
associates negative criteria with low numbers on the scale 
and positive criteria with high numbers on the scale. If you 
create a custom scale, enter values from negative to positive.

You can also:

• Insert comments or edit existing comments about a 
criterion.

• Choose the scale level, up to 10, that voters will use to 
rate the candidate.

• Set up the ballot to let voters evaluate the importance of 
each criterion. Otherwise, all criteria are weighted 
equally.

Add criteria 

1 Under Criteria, type Impact.

2 From Legend, choose Weak…Strong.

3 Press [Enter].

4 Repeat to add the remaining criteria as shown.

5 From Scale, choose 1…9. 

6 Click Finish.
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Casting a vote

The project leader lets voters cast their votes from within the 
Quality Companion project. All voters must have access to 
the shared network drive where the project file is located.

After opening the project, the voter clicks the ballot in the 
Roadmap. From the voter selection page, the voter can:

• Display the ballot by clicking his or her name from the list 
of voters 

• View current voting results by clicking View Results 

When you cast a vote on a rating-vote ballot, you evaluate 
each candidate by criteria chosen by the team. Always read 
rating scales from negative to positive.

If you try to cast an incomplete ballot, Quality Companion 
indicates missing information with a yellow highlight.

Cast a vote

1 Click Bill Rand from the list of voters.

2 Complete the ballot.  

3 Click Cast Ballot. 

4 Click View Results to view current voting results.

5 Click Continue Voting.

6 Close the project so that the next voter can open the project 
to vote.
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Interpreting the results

After the last vote is cast, Quality Companion displays the 
voting results.

Overall Results

The Overall Results table displays the average vote for each 
criteria and the average weighted value for each candidate.

Individual Results

The Individual Results table displays the selection for each 
criteria by voter. This table does not appear if anonymous 
voting was selected during ballot setup.

Our results

The results of this example indicate that 2 options, changes to 
Prep area and Delivery, are likely to provide a quick benefit 
and seem to be most acceptable to the staff and customers.

Interpret results

1 Open 18RatingVote.qcp.

2 Double-click Ballot in the Roadmap.

3 Close the Project Manager for a full view of the results.

4 In the Overall Results Table, right-click the Average column 
header and choose Sort ➤ Descending.
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Setting the consensus threshold

The Consensus Threshold task pane, available only with 
rating-vote ballots, is used to flag areas of disagreement 
among voters. The consensus threshold is represented as a 
number on a scale from 1 to 100. By default, this threshold is 
75, but you can adjust it. A lower number flags more items, 
and a higher number flags fewer.  

When a candidate receives ratings that are especially far 
apart on the scale, it indicates a lack of consensus. In this 
example, the greatest disparity occurs in the Acceptance 
rating for the More staff candidate. The wait staff might 
view More staff as a potential loss of income, but 
management sees this as a way to speed up service.

Set the consensus threshold

1 In the task pane, click Set Consensus Threshold. (If the 
task pane is not open, click  on the standard toolbar.)

2 Check Enable consensus threshold.

3 Drag the indicator button on the slide bar to 40 or type 40 in 
Consensus threshold.

4 Evaluate any areas of disagreement, which are highlighted in 
red. 
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Final considerations

Summary and conclusions

Using the rating-vote ballot, the project leader was able to:

• Allow all team members to vote to choose an 
improvement action, despite schedule conflict

• Review neatly tabulated results

• Flag areas of disagreement among voters with the 
Consensus Threshold

Additional considerations

In this example, voters cast their votes in the project file. 
However, you can also have voters cast votes via e-mail.

1 In Ballot, from the voting page, choose a voter.

2 From the ballot workspace, right-click the ballot and choose 
Copy Ballot. 

3 Paste the ballot in the body of an e-mail. 

4 Delete the voter name.

5 Set the mail format to HTML.

6 Send the e-mail with a request to reply. 

When the recipient chooses Reply, the e-mail becomes 
editable so that the voter can cast and return a vote. 
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Exercise F  Setting up a group multi-vote ballot

Problem

Use a group multi-vote to determine whether the class is 
ready to take a break.

Instructions

1 Add a new ballot to the Roadmap.

2 In Central issue, type Break time?.

3 Under Ballot type, choose Group multi-vote.

4 Click Next. 

5 List Yes and No as the 2 possible candidates.

6 Click Finish.

7 Using a show of hands, vote for the candidates. 

8 Click Cast Ballot and review the results.

Support files

None
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C&E Matrix
Example 3  Use a ballot to complete a form

Problem

The project leader uses a C&E Matrix to identify possible 
causes of the defects at the Add Toppings process step, where 
2% of the pizzas are scrapped and 3% are reworked.

The team wants to use balloting to complete a C&E matrix.

Tools

• C&E Matrix
• Rating-vote ballot

Support files

18Rating Vote.qcp

19Matrix Ballot.qcp
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Opening a C&E Matrix 

The C&E Matrix, or cause-and-effect matrix, quantitatively 
evaluates a set of x inputs versus a set of y outputs. Use a 
C&E Matrix to reduce the list of potential inputs before you 
perform expensive testing.

Open a C&E Matrix

1 Open 18Rating Vote.qcp.

1 Right-click Measure 4 in the Roadmap and choose New ➤ 

Form. 

2 Choose C&E Matrix.

3 Click OK.
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Adding outputs

You can add the outputs, or y variables, to the form manually 
or you can import them from Process Map Data. Y variables 
form the columns in the matrix. These outputs will be 
weighted in terms of importance to the customer.

Add outputs

1 Pause the cursor over a column in the table, click , and 
choose Create New Y Variable ➤ Multiple. 

2 In Number of columns, enter 3.

3 Click OK. 

4 In the output row, double-click each column and type: Correct 
toppings, Attractive look, Correct sauce.

5 Type the importance of each output to the customer. Type 9, 
4, and 7. Press [Tab] to move between fields. 
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Adding inputs

Add outputs, or x variables, to the form manually, or import 
them from Process Map Data. X variables form the rows of 
the matrix.

Add inputs

1 Pause the cursor over a row in the table, click  when it 
appears, and then choose Select Existing X Variables.

2 In the Data Selection dialog box, check the following, and 
then click OK.

3 Pause the cursor over the last row in the table, click  when 
it appears, and then choose Create New X Variable ➤ 
Below.

4 Next to Unmapped Variable, double-click xvariable1 and 
type Wait staff training. 

5 Press [Enter].

Process - Map Activity Name

Process Map - Add toppings Cheese

Process Map - Add toppings Meats

Process Map - Add toppings Vegetables

Process Map - Add toppings Junior cook

Process Map - Add toppings Shell with sauce
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Creating a ballot from table

After it adds the variables to the form, the project team rates 
the effect of each input on each output. Scores are based on 
opinions from the entire team.

You can create a ballot from any form that contains a data 
table. In this example, you create a ballot from the C&E 
matrix, have team members vote on scoring for outputs and 
inputs, and, when voting is complete, import the results 
directly back to the form.

Create a ballot from table

1 Right-click in the data table, and then choose Create Ballot 
from Table.

2 Complete the dialog box as shown below.

3 Click OK.
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Creating a ballot from table

Quality Companion pre-populates the ballot with 
information it already has from the data table in the form. 
Here, the candidates and criteria come directly from the C&E 
matrix. 

Create ballot from table

1 Click Next.

2 Click  to add all team members. 

3 Click Finish.

4 Select any voter and view the resulting ballot. 
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Updating the C&E Matrix

After you rate the inputs and outputs, Quality Companion 
calculates the Weighted Value by Input and % of Net Effect 
by Input. The higher the rated value of an input, the more 
likely that it contributes to the overall effect on the 
organization’s objectives.

Because of their high scores, Meats and Wait staff training 
appear to contribute to the problem. The project leader can 
change their status to critical.

Update the C&E Matrix

1 Open 19Matrix Ballot.qcp.

2 Double-click the C&E Matrix in the Measure 4 section of the 
Roadmap. Notice that the ratings are not in the form.

3 Double-click Ballot 1 in the Measure 4 section of the 
Roadmap and view the results.

4 Click Update Form.

5 Notice that the C&E matrix now contains the results from the 
ballot.  
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Final Considerations

Summary and conclusions

Inadequate wait staff training and wrong meats are thought to 
be the largest contributors to defects at the Add Toppings 
step of the process. Incorrect toppings result when menu 
options are not clearly explained and when cooks receive 
wrong order information. Wait staff training would address 
this problem.

Additional considerations

To evaluate competing improvement proposals, use the 
Solution Desirability Matrix. This team-based form lets you 
select an improvement strategy that best matches the 
improvement goals of your organization.

You can create a ballot from any form that contains a data 
table. For example, you can create a ballot from the Solution 
Desirability Matrix, have team members vote on the 
proposed solutions and, when voting is complete, import the 
results directly back into the form.

Once you choose an improvement strategy, you can use the 
Solution Implementation Checklist to ensure that your team 
has accounted for any potential problems when making 
changes to the process or process input settings.
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