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Step 1: Designate authorized users of multi-user licensing web Basic Installation
pages

Basic Installation

This section provides the basic steps in a typical installation of Minitab 16. For instructions on
advanced installation options, see Installation options on page 12.

To install Minitab 16, follow the steps below. To renew an existing installation that has reached
or is close to reaching its expiration date, see Renewing licenses on page 11.

1 Designate authorized users of multi-user licensing web pages (optional).
2 Determine installation configuration.

3 Create license files at the multi-user licensing web pages.

4 Obtain software.
5

Install software.

Note This installation guide applies only to the multi-user installation for Minitab products.
If you are not sure whether you have a multi-user or single-user license, see
www.minitab.com/support/answers/answer.aspx?id=2517.

Step 1: Designate authorized users of
multi-user licensing web pages

To access the Minitab multi-user licensing web pages so that you can create the license files
for the installation, you must be either the Minitab License Coordinator for your organization
or an authorized user.

At the time of purchase, someone from your company was designated as the Minitab License
Coordinator. That person has permission to log in to the Minitab multi-user licensing web
pages to create license files. In addition, your company can have other authorized users.

If you are not sure whether you're an authorized user, contact your organization's Minitab
License Coordinator. Only the License Coordinator can request additional authorized users
by contacting a Minitab sales representative or Minitab Technical Support.

Step 2: Determine installation configuration

All multi-user installations require Minitab License Manager, the software that manages Minitab
based on the information in the license file. Minitab License Manager must be installed in a
configuration that allows it to communicate with Minitab.

You can choose from several different installation configurations to suit your needs. For example,
you can install Minitab License Manager on a server in a networked configuration. In a
networked configuration, users access the license file on the server; therefore, each client
computer does not need to be permanently assigned to a separate license file. Another option
is to install Minitab License Manager and Minitab on each client computer in a standalone
configuration, which requires a separate license file for each client computer.

The installation configuration you choose affects the number of license files you need to create
and the installation procedures that you need to follow. See Installation Configurations on page
6 for detailed information that will help you to determine the best configuration for your
organization.
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Step 3: Create license file(s) Basic Installation

To create
license files

To download
software

Step 3: Create license file(s)

You need at least one license file for installation. To create license files, you use the Minitab
multi-user licensing web pages. One license file per server is required in a networked installation.
One license file per workstation is required in a standalone configuration. See Installation
Configurations on page 6 for more information on networked and standalone configurations.

You need the following information to create a license file:

¢ The maximum number of simultaneous users that will be served by the license. In a

standalone configuration, the maximum number of users is 1 for each license.

To determine the maximum number of users in a networked configuration, see Number of
license files on page 9.

The MAC address of each computer that will host a license. This is the computer's physical
address. To obtain the address, run the DOS command "ipconfig /all" and record the
physical address that appears under Ethernet adapter Local Area Connection. In the example
below, the MAC address of the computer is 01-23-45-AB-CD-EF.

Ethernet adapter Local Area Connection:

Connection-specific DNS Suffix.:domain.local

Description....................:Broadom NetXtreme 57XX Gigabit
Controller

Physical Address............... 01-23-45-AB-CD-EF

Dhcp Enabled...................:Yes

Autoconfiguration Enabled......:Yes

IP Address.....................:192.168.1.1

Subnet Mask....................:255.255.255.0

Default Gateway................:192.168.2.100

DHCP Server....................:192.168.2.100

DNS Server..........ceeevee....:192.168.10.200

Lease Obtained.................:Saturday, July 25, 2009 4:07:19 PM

Lease Expires..................:Wednesday, July 29, 2009 4:07:19 PM

For more information on how to obtain a computer's MAC address, see
www.minitab.com/support/answers/answer.aspx?id=2084.

1 Go to http://www.minitab.com/manage-license-files.aspx.
2 Log in as an authorized user.

3 Complete the necessary steps to create the license file(s).

Step 4: Obtain software

All multi-user configurations require both Minitab License Manager and Minitab. The
installation files for these applications are available on the installation CD. However, to ensure
that you have the latest version of our products, download the applications from the Minitab
Web site using any Minitab.com account.

Go to http://www.minitab.com/support/licensing/multi-user/downloads/default.aspx.

Download Minitab License Manager and Minitab. The license file is read by Minitab
License Manager, the server software that manages the use of Minitab based on the
information in the license file.
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Step 5: Install software Basic Installation

Step 5: Install software

Install Minitab and Minitab License Manager based on the installation configuration that you
determined in step 2. You can install Minitab License Manager on a server in a networked
configuration or on each client computer in a standalone configuration.

Note ‘ We recommend that you disable your anti-virus software during the installation of
Minitab 16.

System  You can find the latest system requirements for Minitab at
requirements  http://www.minitab.com/products/minitab/system-requirements.aspx.

Toinstallina 1 Ensure that you have administrative privileges to install Minitab License Manager on the
networked server and Minitab on each workstation.

configuration 5 e that the license file is on the desktop of the server. See Create License File(s) on

page 4 for more information.
3 Install Minitab License Manager on the server.

4 Delete the license file that is on the desktop. The installation program creates a copy of the
license file in C:\Program Files\Minitab\License Manager. The Minitab License Manager
uses this license file.

5 Install Minitab on each workstation.
®  You need to specify the name of your Minitab License Manager server during installation.

® Minitab chooses the first available port between 27000 and 27009. If your License
Coordinator specified a different port within the license file, check Specify port number,
and enter that port number.

Note After you set up a networked configuration, you can use the Minitab License Borrowing
Utility to allow a portable workstation, such as a laptop, to run Minitab products while
itis disconnected from the network. See Using Minitab products while disconnected from
the network on page 6 for more information. Borrowing is not available in all regions.
See www.minitab.com/support/answers/answer.aspx?id=2449 to determine whether
your license is borrow-enabled.

Toinstallina 1 Ensure that you have administrative privileges to install Minitab License Manager and
standalone Minitab on each workstation.

configuration

[N ]

Ensure that the license file is on the desktop of the workstation. See Create License File(s)
on page 4 for more information.

3 Install Minitab License Manager on each workstation.

4 Delete the license file that is on the desktop. The installation program creates a copy of the
license file in C:\Program Files\Minitab\License Manager. The Minitab License Manager
uses this license file.

5 Install Minitab on each workstation.
¢  When prompted for the name of the Minitab License Manager server, enter localhost.

e Minitab chooses the first available port between 27000 and 27009.
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Multi-user installation Installation Configurations

Installation Configurations

Basic Installation on page 3 explained how to install the multi-user version of Minitab products.
This section provides a more in-depth explanation of the client-server model and the possible
installation configurations.

Multi-user installation

The multi-user versions of Minitab products are based on a clientserver installation model.
Minitab (the client software) is installed on individual workstations. Minitab License Manager
(the server software) is installed on a server. Every time the client software is started, it
communicates with the server to ensure that a license is available.

Typically, Minitab License Manager is installed on a single server. The client software can be
installed on an unlimited number of workstations. Minitab License Manager ensures that the
number of concurrent users never exceeds the licensed number of seats.

For example, an organization purchased 100 licenses of Minitab and configured Minitab
License Manager to control all 100 licenses. Minitab was installed on 300 workstations. Even
though the client software has been installed on 300 workstations, Minitab License Manager
will allow only 100 instances of the client software to run concurrently.

When the client software is started, it requests a license from Minitab License Manager. If a
license is available, it is sent it to the client and the software starts successfully. If a license is
not available, an error message is displayed.

Configuration options

Networked  To set up a networked configuration, install Minitab License Manager on a server. A license
configuration file is requested during the installation process. You need to provide the license file that was
created during the procedure detailed in Basic Installation on page 3 (license files should
always be named "minitab.lic"). Minitab License Manager is installed to C:\Program
Files\Minitab\License Manager (by default). The installation program makes a copy of the
license file and places it in the installation directory.

The Minitab License Manager installation creates a Windows service called Minitab License
Manager. The license manager service starts automatically when it is installed. When the service
starts, it checks the Minitab License Manager installation directory for the license file. If the
license file is valid, the service starts successfully.

Install the client software, Minitab, on as many workstations as necessary. During installation,
you need to provide the name of the server on which Minitab License Manager is installed.

Using Minitab  In a multi-user installation of Minitab, the client software must be able to communicate with
products the Minitab License Manager server to start. To allow a portable workstation, such as a laptop,
while  torun Minitab products when it is disconnected from the network, Minitab provides the Minitab

disconnected  License Borrowing Utility.

from the  For example, you might use Minitab on a laptop when you travel for business. Before leaving,

network  while still connected to your company's network, use the Minitab Borrowing Utility to acquire
alicense from the Minitab License Manager server. Then you can access Minitab on the laptop
when you are disconnected from the network.
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Minitab License Manager Installation Configurations

Standalone
configuration

Mixed
configurations

To restart
Minitab
License

Manager

For more information, refer to License Borrowing Instructions. Go to
http:/lwww.minitab.com/support/licensing/multi-user/documentation/default.aspx. To download
the Minitab License Borrowing Tool, go to
http:/www.minitab.com/support/licensing/multi-user/downloads/default.aspx.

Note Borrowing is not available in all regions. See
www.minitab.com/support/answers/answer.aspx?id=2449 to determine whether your
license is borrow-enabled.

In a standalone configuration, Minitab products do not depend on accessing a network server.
Instead, the Minitab License Manager server software is installed on the same workstation as
the client software, Minitab. When Minitab starts, it checks the Minitab License Manager
service that is on the same workstation, regardless of network connectivity. An individual license
file must be created for each workstation.

You can use a combination of networked and standalone configurations. For example, you can
install Minitab on 20 workstations that are connected to the company's network and also install
Minitab on 5 standalone workstations that are not connected to the network.

For information on mixed installation configurations and license files, see Number of license
files on page 9.

Minitab License Manager

All multi-user installation configurations require the installation of the Minitab License Manager,
the server software that manages the use of Minitab. The Minitab License Manager ensures
that the number of concurrent users does not exceed the licensed number of seats, based on
the information in the license file.

The Minitab License Manager starts its service automatically when you install it. However, you
may need to restart the Minitab License Manager service in some cases, such as when you
make changes to the license file or use an options file.

1 Open Windows services on the computer:

® In Vista or later, click the Windows logo (Start). Type services.msc in the search box
and press Enter.

® In other Windows versions, choose Start > Run. Type services.msc and click OK.

2 Click Minitab License Manager.

3 Choose Action > Restart.

Note If you need to uninstall Minitab License Manager from a computer, such as when you
change servers or installation configurations, you must first stop the license manager
service. Follow steps 1 and 2 above; in step 3, choose Action > Stop. Then uninstall
the Minitab License Manager.
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Using license files License Files

License Files

License files are required for the installation of Minitab multi-user products. This section
provides general background information on license files, including what they are, where they're
created and stored, and how they're used. For instructions on how to work with license files
after installation, see License Manager Ultility on page 14.

Using license files

Whatisa  Alicense file is a text file named minitab.lic. The file does not have a .txt extension, but you
license file? can open it in a standard text editor such as Notepad. The file contains information about the
licenses that your organization purchased. This information includes the expiration date, the
number of licenses, and the computer's MAC address.

After you create a license file at the Minitab multi-user licensing web pages, save it to the
desktop of the computer on which you will install the Minitab License Manager, the server
software that manages the use of Minitab based on the information in the license file.

Sample license file

SERVER this_host 0A1B2C3D4ESF

VENDOR minitab

USE_SERVER

INCREMENT Minitab minitab 16 31-dec-2011 100 VENDOR_STRING="T1limited \
term, limited users, borrowing enabled" DUP_GROUP=UH \
ISSUER=Minitab ISSUED=01-jan-2011 BORROW=26280 \
NOTICE="Customer ID: 01234 License Coord ID: 56789 \
RENIQ1234" SN="STDORD56789 01234INC" START=01-oct-2010 \
SIGN="1c71 F7B8 641F 7A84 F052 9650 F5E6 B093 ACBC 04C4 AF4D \
5B3B OF38 C3FB DF49 1720 F1BA D1CD 646D 4C9D 824B E7A9 F724 \
3EDA 9B09 5628 733F F646 AC87 6C39"

In the sample license file above, the terms in bold specify the following information:

0A1B2C3DA4ESF the unique MAC address of the computer for which this license
file was created.

minitab 16 the name of the product for which the license file was created.

31-dec-2011 the expiration date of the license file.

100 the number of users allowed to concurrently run Minitab.

Fach license file is created for a single computer. The computer is identified in the license file
by its MAC address. The license file cannot be used on a computer that does not have the
MAC address specified in the license file.

How license  During the installation of Minitab License Manager, you need to provide the location of the
files are used license file. By default, the installation looks to the desktop for the license file and then creates
a copy of the license file in C:\Program Files\Minitab\License Manager. The Minitab License
Manager service is then installed. The service reads the license files and then starts.

Note After you install Minitab License Manager, you can delete the license file that is on the
desktop.
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Adding a second product or additional users to your license License Files
file

Authorized users can create license files at the Minitab Multi-User Licensing web pages. See
Create License File(s) on page 4 for more information.

Number of  You need one license file for each Minitab License Manager that you install. In a typical

license files networked configuration, Minitab License Manager is installed on a single server. In this case,
only one license file is needed. For example, Minitab License Manager is installed on a single
server that will serve all 100 licenses. You need to create a single license file for all 100 seats.

You can also divide your licenses among multiple servers, if desired. For example, Minitab
License Manager is installed on two servers, one for 75 users in Department A and the other
for 25 users in Department B. This installation configuration requires two license files: one file
for 75 seats and another file for 25 seats.

In a standalone configuration, Minitab License Manager must be installed on each workstation.
As a result, a unique license file is required for each installation of Minitab License Manager.
For example, a small computer training lab has 10 computers that are not networked. You need
to install Minitab and Minitab License Manager on all 10 computers. This installation
configuration requires 10 license files, one for each computer.

You can have a combination of networked and standalone installations. You need to create a
single license file for the server and a separate license file for each standalone workstation. For
example, an organization purchases 100 licenses for Minitab. They want 10 standalone
installations in the computer lab. A single server will host the remaining 90 licenses. This
installation configuration requires 11 license files: one for the server and one for each of the
10 standalone workstations.

Adding a second product or additional users
to your license file

When you purchase both Minitab Statistical Software and Quality Companion, you must
initially create two separate license files at the multi-user licensing web pages, one for each
product. However, to install both products, you need to merge the two license files into one
file. After you download both license files, append the contents of one license file to the other
license file.

You can also add additional users to your license, which also involves appending the contents
of your new license file to the existing file.

To append an 1 At hitp://www.minitab.com/manage-license-files.aspx, create a separate license file for the
additional additional product.

pr(?dUCt to_ A 2 Save the new license file to the desktop. Do not overwrite the existing license file in
license file C:\Program Files\Minitab\License Manager.

Open the new license file for the additional product in Notepad.

Copy everything from the INCREMENT line down.

Close the license file that is on the desktop.

Open the original license file in C:\Program Files\Minitab\License Manager in Notepad.

Paste the copied contents of the new license file to the end of the original license file.

coO 31 N VI A~ W

Choose File > Save.
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Adding a second product or additional users to your license License Files

file

Example of a
license file
with
appended
product

To append
additional
users to a
license file

9 Restart the Minitab License Manager service. See To restart Minitab License Manager on
page 7 for more information.

10 To verify your change, double-click Imtools.exe in the installation directory (by default,
C:\Program Files\Minitab\License Manager).

11 Click the Server Status tab.
12 Click Perform Status Enquiry.

13 In the results window, look for the line that includes Users of product where product =
the Minitab product you added to your license.

SERVER this_host 0A1B2C3D4ESF

VENDOR minitab

USE_SERVER

INCREMENT Minitab minitab 16 31-dec-2011 50 VENDOR_STRING="1limited \
term, limited users, borrowing enabled" DUP_GROUP=UH \
ISSUER=Minitab ISSUED=01-jan-2011 BORROW=26280 \
NOTICE="Customer ID: 01234 License Coord ID: 56789 \
RENIO1234" SN="STDORD56789 01234INC" START=01-oct-2010 \
SIGN="1C71 F7B8 641F 7A84 F052 9650 F5E6 B093 ACBC 04C4 AF4D \
5B3B OF38 C3FB DF49 1720 F1BA D1CD 646D 4C9D 824B E7A9 F724 \
3EDA 9B09 5628 733F F646 AC87 6C39"

INCREMENT qualitycompanion minitab 3 31-jan-2012 8 VENDOR_STRING="Tlimited \
term, limited users, borrowing enabled" DUP_GROUP=UH \
ISSUER=Minitab ISSUED=01-mar-2011 BORROW=26280 \
NOTICE="Customer ID: 01234 License Coord ID: 56789 \
RENIO1234" SN="STDORD31415 01234INC" START=01-nov-2010 \
SIGN="1EA6 00D1 E785 EEA9 F026 63B5 BBA® B8BO CAB9 \
91CA A57A D123 D9DD 0372 A1CD 136F 12F4 ABCB EAGA 3AD9 A71F \
FO014 7B78 A683 6EB2 FCC6 9685 OD66 6355 441C"

1 At http://www.minitab.com/manage-license-files.aspx, create a separate license file for the
additional users.

2 Save the new license file to the desktop. Do not overwrite the existing license file in
C:\Program Files\Minitab\License Manager.

Open the new license file for the additional users in Notepad.

Copy everything from the INCREMENT line down.

Close the license file that is on the desktop.

Open the original license file in C:\Program Files\Minitab\License Manager in Notepad.
Paste the copied contents of the new license file to the end of the original license file.

Choose File > Save.

N el R N =) B NV ]

Restart the Minitab License Manager service. See To restart Minitab License Manager on
page 7 for more information.

10 To verify your change, double-click Imtools.exe in the installation directory (by default,
C:\Program Files\Minitab\License Manager).

11 Click the Server Status tab.
12 Click Perform Status Enquiry.
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Renewing licenses License Files

13 In the results window, look for the line that includes Total of x licenses issued and
confirm that x is equal to the total number of licenses (original + added).

Example of a  SERVER this_host 0A1B2C3D4ESF
license file  VENDOR minitab

. USE_SERVER
with INCREMENT Minitab minitab 16 31-dec-2011 100 VENDOR_STRING="T1limited \
appended term, limited users, borrowing enabled" DUP_GROUP=UH \
ISSUER=Minitab ISSUED=01-jan-2011 BORROW=26280 \
users NOTICE="Customer ID: 01234 License Coord ID: 56789 \

RENIQ1234" SN="STDORD56789 01234INC" START=01-oct-2010 \
SIGN="1c71 F7B8 641F 7A84 F052 9650 F5E6 B093 ACBC 04C4 AF4D \
5B3B OF38 C3FB DF49 1720 F1BA D1CD 646D 4C9D 824B E7A9 F724 \
3EDA 9B09 5628 733F F646 AC87 6C39"

INCREMENT Minitab minitab 16 31-jan-2012 25 VENDOR_STRING="limited \
term, limited users, borrowing enabled" DUP_GROUP_UH \
ISSUER=Minitab ISSUED=01-mar-2011 BORROW=26280 \
NOTICE="Customer ID: 01234 License Coord ID: 56789 \
RENIQ1234" SN="STDORD31415 01234INC" START=01-nov-2010 \
SIGN="1c71 F7B8 641F 7A84 F052 9650 F5E6 B093 ACBC 04C4 AF4D \
5B3B OF38 C3FB DF49 1720 F1BA D1CD 646D 4C9D 824B E7A9 F724 \
3EDA 9B09 5628 733F F646 AC87 6C39"

Renewing licenses

To avoid "checkout failed" error messages that are caused by expired license files, renew your
organization's Minitab license before it expires.

1 Your organization's License Coordinator must purchase a new license for your organization.

2 An authorized user must log in and generate new license files at
http://lwww.minitab.com/manage-license-files.aspx.

See Step 3: Create license file(s) on page 4 for more information about creating license

files.

3 Replace the existing license file with the new license file in C:\Program
Files\Minitab\License Manager.

4 Restart Minitab License Manager. See To restart Minitab License Manager on page 7 for
more information.

Note License files are created with an expiration date. Minitab will not start if the license is
expired.
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Advanced Topics

Installation options

When you install Minitab, you can choose several advanced installation options. After you
choose the language, accept the license agreement, and enter license manager information,
click Advanced to:

¢ Change the destination folder. By default, Minitab is installed to C:\Program Files\Mintab
in the Minitab 16 folder.

e Install a desktop shortcut.

e Install the Minitab Software Update Manager.

Note If you choose not to install the Minitab Software Update Manager on your computer
or those of your end-users, you will not be informed of critical software updates. Without
the Minitab Software Update Manager, you will not be able to easily identify which
updates apply to the software version that is installed on your computer(s). We
recommend that you install the Minitab Software Update Manager on at least one
regularly monitored computer so that you can receive notices and updates.

To perform an After you add license manager information, click Next and then click Advanced.

advanced

. . If you like, type a new destination folder or click Change to browse to a different location.
installation

Click Next.

Check Install a desktop shortcut to include a desktop shortcut to Minitab.
Check Install Minitab Software Update Manager.

Click Install.

AN V1T AW N =

Installing additional languages

Minitab 16 is available in English, French, German, Japanese, Korean, Simplified Chinese,
and Spanish. You can install one or more than one language pack on any client computer.

Toinstall 1 Go to http:/www.minitab.com/support/licensing/multi-user/downloads/default.aspx.

Iaddltlonal 2 Follow the instructions to install additional language packs of Minitab 16.
anguages
from a ¢ Ifyou already have one language pack of Minitab installed, you can install one or more
downloaded additional languages.
file ¢ Ifyou did not already install Minitab, you must install the software before you add

additional languages. However, to save time, you can download the full image that
includes all language packs of the software. When you install the software, you can install
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Checking for updates

To install
additional
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updates
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Advanced Topics

the language pack(s) that you want by using the Minitab Customization Tool or
command line installation.

Note If you plan to use the Minitab Customization Tool for deployment, download the full

image with all language packs. For more information, see Customizing your deployment
on page 16 .

Before you can install additional languages, you must first have at least one language version
of Minitab 16 installed on your computer.

1 Insert the CD. If a splash screen does not appear, double-click AutorunSetup.exe on the
disk.

2 Click Install Additional Languages.
3 Check any additional language packs to install.

Note

You can choose only language packs that are not yet installed. For example, if the
Spanish version of Minitab is already installed, Spanish will not be listed as a
language pack that you can add.

4 Click Next.
5 Click Finish.

Checking for updates

If you installed the Minitab Software Update Manager, it automatically checks for updates
every month and gives each user the ability to manually check for updates at any time.

1 Open Minitab.
2 Choose Help > Check for Updates.

3 Select the updates you want and click Install update(s).

You can change how often the Update Manager automatically checks for updates.
1 Open Minitab.

2 Choose Help > Check for Updates.

3 Click Preferences.

4 Choose Daily, Weekly, Monthly, or Never.

5 Click OK

Note If you choose Never to check for updates, you will not be automatically informed of
critical updates, bug fixes, or notifications of problems or errors. However, Minitab

users can still check for Minitab updates manually.
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To specify a
license
manager port

License manager utility

Flexera Software, formerly Acresso, provides the Imtools.exe utility for performing license
management tasks. This utility provides a graphical user interface to access all the license
management tasks. To use LMTOOLS, navigate to the license manager installation folder

(C:\Program Files\Minitab\License Manager by default) and double-click Imtools. exe.

For more information on LMTOOLS, refer to the FLEXnet Licensing End User Guide distributed
by Flexera Software.

You can use this utility to check the status of Minitab License Manager and to help you monitor
network licensing activities, such as the number of licenses in use and who is using them. You
can also review configuration settings. See Check Minitab License Manager status and settings
on page 19 for more information.

Specifying ports

Minitab uses two ports for communication between the workstation and the server: the license
manager (Imgrd.exe) port and the vendor daemon (minitab.exe) port. You can modify the
license file to specify which port numbers Minitab should use.

Specifying ports manually is useful when you need to identify them as open ports on firewalls.
When communication appears to be blocked, configure these open ports on any firewall on
or between the workstation and server, including software firewalls such as Windows firewall.
See FLEXnet error 96 on page 21 for more information.

You can specify both the license manager and vendor daemon ports in the same license file.
Make a backup of your license file before you edit it.

The license manager (Imgrd.exe) automatically chooses the first available port between 27000
and 27009 each time the Minitab License Manager service starts. You can set this port number
to a permanent value.

1 Open the license file in C:\Program Files\Minitab\License Manager in Notepad.

2 Type the port number after the MAC address on the first line. Leave a space between the
MAC address and port number, as shown in the example below step 7.

3 Save the file.

4 Restart the Minitab License Manager service to re-read the license file. See To restart Minitab
License Manager on page 7.

5 o verify your change, open the Minitab License Manager log file, minitab.dl, which is
located at C:\Program Files\Minitab\License Manager, in Notepad.

6 Locate the line that includes 1mgrd tcp-port.

7 Make sure that the port number on this line is correct. For example, Imgrd tcp-port
27001 .

Example of license file with specified license manager port of 27001:

SERVER this_host 0A1B2C3D4ES5F 27001

VENDOR minitab

USE_SERVER

INCREMENT Minitab minitab 16 31-dec-2011 100 VENDOR_STRING="1limited \
term, limited users, borrowing enabled” DUP_GROUP=UH \
ISSUER=Minitab ISSUED=01-jan-2011 BORROW=26280 \
NOTICE="Customer ID: 01234 License Coord ID: 56789 \
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Advanced Topics

RENIO1234” SN="STDORD56789 01234INC” START=01-oct-2010 \
SIGN="1C71 F7B8 641F 7A84 F052 9650 F5E6 B093 ACBC 04C4 AF4D \
5B3B OF38 C3FB DF49 1720 F1BA D1CD 646D 4C9D 824B E7A9 F724 \
3EDA 9B09 5628 733F F646 AC87 6C39”

The four-digit vendor dacmon (minitab.exe) port is dynamically assigned from a wide range of
port numbers each time the Minitab License Manager service starts. You can set this port
number to a permanent value.

1 Open the license file in C:\Program Files\Minitab\License Manager in Notepad.

2 Type port= and the port number at the end of the second line ("port" is case-sensitive).
Leave a space between minitab and port=.

3 Save the file.

4 Restart the Minitab License Manager service to re-read the license file. See 'lo restart Minitab
License Manager on page 7.

5 'To verify your change, open the Minitab License Manager log file, minitab.dl, which is
located at C:\Program Files\Minitab\License Manager, in Notepad.

6 Locate the line that includes minitab using TCP-port.

7 Make sure that the port number on this line is correct. For example, minitab using
TCP=port 3000 .

Example of license file with specified vender daemon port of 3000:

SERVER this_host 0A1B2C3D4ES5F

VENDOR minitab port=3000

USE_SERVER

INCREMENT Minitab minitab 16 31-dec-2011 100 VENDOR_STRING="T1imited \
term, limited users, borrowing enabled” DUP_GROUP=UH \
ISSUER=Minitab ISSUED=01-jan-2011 BORROW=26280 \

NOTICE="Customer ID: 01234 License Coord ID: 56789 \

RENIQ1234” SN="STDORD56789 01234INC” START=01-oct-2010 \

SIGN="1C71 F7B8 641F 7A84 F052 9650 F5E6 B093 ACBC 04C4 AF4D \

Options file

You can use the options file to control various license system options for the Minitab License
Manager, such as reserving licenses for a person or group or excluding licenses for a person or

group.

1 Open a new file in Notepad.

[N

Type your settings with the appropriate syntax, as documented in the FLEXnet Licensing
End User Guide distributed by Flexera Software, formerly Acresso. See the bottom of this
topic for an example options file.

3 Choose File > Save As and browse to the same folder as minitab.lic (C:\Program
Files\Minitab\License Manager).

In File name, type minitab.opt.
In Save as Type, choose All Files.
Click Save.

~N O V1 b

Restart the Minitab License Manager service. See To restart Minitab License Manager on
page 7.
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To use the
Minitab
Customization
Tool

8 To verify that the options file is successfully implemented, open the Minitab License
Manager log file, minitab.dl, at C:\Program Files\Minitab\License Manager, in Notepad.

9 Locate the line that includes Using options file:<path_to_options_file>. If this text
is present, the options file has been successfully implemented.

If a minitab.opt is present, the Minitab License Manager service reads it and implements the
settings in the file.

In the example below of an options file, line 1 prevents the user tjones from using Minitab.
Line 2 prevents the same user from using Quality Companion. Line 3 creates a group named
"quality" and defines members of that group. Line 4 reserves three licenses for the quality group.
EXCLUDE Minitab USER tjones

EXCLUDE qualitycompanion USER tjones

GROUP quality jsmith bmiller awilson
RESERVE 3 minitab GROUP quality

Note Go to www.minitab.com/support/answers/answer.aspx?ID=2344 for more information
about the options file.

Customizing your deployment

The Minitab Customization Tool is a graphical user interface that you can use to create a
custom deployment of Minitab 16. The tool creates a configuration file that you can use when
you deploy Minitab.

Use the instructions below to set up a custom deployment. To access Setup Help at any time,
type setup.exe /help at the command prompt.

1 Copy the installation files to a network location. Make sure you use the installation files
from the CD, or download the full image with all language packs from the Minitab Web
site.

2 Open the command prompt and navigate to the Minitab 16 installation files.
3 Type Setup.exe /admin and press Enter to access the Minitab 16 Customization Tool.

4 Choose the language to use during customization and click OK. (You are not prompted to
choose a language if Minitab is already installed on this computer.)

Set the options for deployment.

6 Choose File > Save to save the configuration file, config.xml, to the directory that contains
setup.exe. Ensure that these files are in a network location that can be accessed by the
computers onto which you will install Minitab 16. Alternately, you can save config.xml to
a different location and reference it on the command line using this syntax: setup.exe /config
"path" (for example, setup.exe /config "\ServerName\PathTo\config.xml"). See Command
line installation on page 17 for more information.

Note If you did not copy the installation files to a network location in step 1, you can
check Copy Installation Files to save both the installation files and the configuration
file to the same network location.
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7 Click Save.

If you use SMS, Altiris, Tivoli, or another enterprise management tool for deployment, use
setup.exe to deploy Minitab.

If you use Active Directory/Group Policy for deployment, use one of these methods to deploy
Minitab:

e Startup Script (recommended)
1 Create a configuration file using the Minitab 16 Customization Tool.
2 Ensure that the config.xml file is next to the setup.exe.

3 Call setup.exe within a Startup Script in Active Directory.

®  Group Policy Software Deployment (assignment only; updates not supported)
1 Create a configuration file using the Minitab 16 Customization Tool.
2 Ensure that the config.xml file is next to the setup.exe.

3 Assign the core.msi to the GPO (Group Policy Object). You can find this .msi in the
administrative package that you created under the Core folder (Core/Core.msi).

If you silently deploy Minitab through Group Policy, setup.exe continues to run in the
background even after the user logs on and until the installation is complete.

If you use Organizational Defaults to set the default Minitab user profile, you must save the
orgdefs.reg file next to the language pack MSI for each language you install. For more
information, see Identical settings on multiple computers on page 17.

Command line installation

You can use the command line to install Minitab 16 on the client computer. Use the Minitab
Customization Tool to create a configuration file to use for command line installation. You

can specify all configurable settings for installation in the configuration file. To do so, you must
specify the license information for each installation using the appropriate command line syntax.

From the client computer, execute the following as one continuous line of text, substituting
your information for italicized text:

setup.exe /config config.xml
config.xml is the file that you create with the Minitab Customization Tool.

setup.exe /help displays a full list of command line switches that are available with setup.exe.

Identical settings on multiple computers

To ensure that multiple computers have identical Minitab 16 settings, you can use Tools >
Manage Profiles to create and export a preinstall profile as a registry file named OrgDefs. reg
and include it with the installation files.
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This process requires that you open Minitab with its original (unmodified) profile settings.
Therefore, it is reccommended that you log in to your computer as a user that has not previously
modified Minitab profile settings.

To implement 1
a preinstall

Open Minitab on a computer that does not have any modified profile settings. If you are
unsure whether the profile settings have been modified, open Minitab using an Administrator

profile account that has not previously been used to open Minitab.

2 Adjust any settings that you want to share on multiple computers.

3 Choose Tools > Manage Profiles.

4 Move MyProfiles from Active profiles to Available profiles by clicking the arrow. (To be
exported, profiles must be under Available profiles.)

5 With the profile selected, click Export.

6 In Save In, browse to the network folder that contains the Minitab 16 installation files.

7 Browse to the LanguagePacks folder. Open the appropriate language folder and save the
OrgDefs.reg file.

8 In File name, rename MyProfile to OrgDefs.reg. Click Save.

When Minitab is installed, OrgDefs.reg is put in the user’s Minitab 16\Language\Profiles

folder.

Note If you do not include the custom profile with the installation files, you must copy it to

each user's Minitab 16\Language\Profiles folder after installing but before
opening Minitab for the first time. Therefore, we recommend that you include the
custom profile with the installation files and allow the installation to install it for you.
On Vista and newer computers, the Program Files folder is protected. If you have
installed Minitab to this protected area (which is the default), the profile must be copied
totheMinitab 16\Language\Profiles folder by a user with administrative-level
access for all system users to have access to it.

When a user opens Minitab for the first time, the file is imported. The imported profile is
named $$OrganizationDefaults. For more information on profiles, type Profiles in the Minitab
Help index.
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This section provides information for troubleshooting problems related to licensing and installing
Minitab products.

Log files

Minitab 16 and Minitab License Manager each generate log files to use for troubleshooting.

An installation log file is created when you install Minitab 16 . The file is named setup.log and
is located at % TEMP%\Minitabl6 .

The installation log file contains information such as the time and date of installation and the
folder to which the software was installed.

In Windows XP:

1 From the Windows taskbar, choose Start > Run.
2 In Open, type ¥TEMP%\Minitab1l6.

3 Click OK

4 Browse to Setup.log.

In Windows Vista or Windows 7:

1 Click the Windows logo (Start).

In Start Search, type ¥TEMP%\Minitab16.

Press Enter.

SWwWw N

Browse to Setup.1log.

Minitab License Manager is the server software that controls the use of your license. It generates
alog file that is updated with events, such as license check-ins, check-outs, and error messages.
By default, the log file is named Minitab.dl and is located at C:\Program Files\Minitab\License
Manager.

To read the Minitab License Manager log file, open it in Notepad.

Note For detailed information on the Minitab License Manager log file, refer to the FLEXnet
Licensing End User Guide distributed by Flexera Software, formerly Acresso.

You can check the status of Minitab License Manager to help you monitor network licensing
activities, such as the number of licenses in use and who is using them. You can also review
configuration settings.

1 Navigate to Minitab License Manager folder (by default, at C:\Program Files\Minitab\License
Manager).

2 Double-click Imtools.exe.
3 Do any of the following:

e To check server status, click the Server Status tab. Click Perform Status Enquiry.
¢ To check server configuration, click the Config Services tab.
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FLEXnet license errors

FLEXnet error
15

FLEXnet error
25

FLEXnet error
34

Troubleshooting

¢ To check license information, click the Server Diags tab. Click Perform Diagnostics.

The number of licenses are listed, as shown in this example:

Users of Minitab:
use)

(Total of 50 licenses used; Total of 33 licenses in

Specific details about each license are also listed:
jsmith LAB_PCLAB_PC (v1.0)(LAB_PC/27000 302), start Fri 3/1 4:15

jsmith is the user name, LAB_PC is the computer name, and 27000 is the license

manager port

Borrowed licences display the expiration in seconds. For example, the license below

will expire in 314159 seconds:

jsmith LAB_PCLAB_PC (v1.0)(LAB_PC/27000 302), start Fri 3/1 4:15 (linger:

314159)

FLEXnet license errors

You may encounter several types of FLEXnet error messages that indicate that you cannot
check out a license. These messages are formatted in general as follows:

FLEXNET License Error Number:

For example:

Error text.

FLEXNET License Error -97-121-0: Check out failed

Some of the errors that you may encounter are listed below. For a complete list of possible error
codes, see the FLEXnet Licensing End User Guide.

Possible cause

Explanation

The server name that was provided during the
installation of Minitab 16 on the client
computer is not valid.

Possible cause

The server name that was provided during the
installation of Minitab 16 on the client
computer is used to locate that server on the
network. Make sure that the server name is
valid. For instructions on locating the server
name, see
www.minitab.comy/support/answers/answer.aspx?id=2085.

Explanation

You are using Minitab 16 with a Minitab 15
license file.

Possible cause

The license file that is managed by Minitab
License Manager only supports Minitab 15. To
resolve this, you need to create a new license
file for Minitab 16.

Explanation

The date differs in excess of 24 hours between
the client computer and the Minitab License
Manager server.
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FLEXnet license errors

FLEXnet error
92

FLEXnet error
68

FLEXnet error
95

FLEXnet error
96

FLEXnet error
97

Possible cause

Troubleshooting

Explanation

Possible cause

the license. Reset the clock on the client
computer.

Explanation

The MAC address in the license file does not
match the MAC address of the Minitab License
Manager server.

Possible cause

The MAC address in the license file must match
the MAC address of an enabled network
adapter on Minitab License Manager. See
License Files on page 8 for more information.

Explanation

The license file is not configured to allow for
borrowing.

Possible cause

Not all licenses are borrow-enabled.
Borrow-enabled licenses will have
"borrow-enabled" within the text of the license
file.

Explanation

You are browsing to a license file in a
standalone configuration.

Possible cause

Your license type may not support this method.
In the Find License dialog box, instead of
choosing Specify the License File, choose
Specify the License Server System. Type the
server name. For example, type @localhost.

Explanation

Firewalls or network configurations are blocking
communications between the client computer
and the Minitab License Manager server.

The client computer must be able to
communicate with the Minitab License
Manager server over two ports: the Minitab
License Manager (Imgrd.exe) port and the
minitab vendor daemon (minitab.exe) port.
You can use telnet to test communications. See
wwwminitab.com/support/answers/answer.aspx?id=2178
for more information on telnet. See the Minitab
License Manager log file on page 19 to
determine which port numbers are used. See
Specifying ports on page 14 to manually
configure ports.

The Minitab License Manager service is not
running on the license server.

Possible cause

The Minitab License Manager service must be
running to process license requests for Minitab.

Explanation

The MAC address in the license file does not
match the MAC address of the Minitab License
Manager server.

The MAC address in the license file must match
the MAC address of an enabled network
adapter on Minitab License Manager. See
License Files on page 8 for more information.

The license expired.

The expiration date for your license is specified
in the license file. Minitab is not usable after

Minitab 16 Installation Guide
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Minitab License Manager fails to start

FLEXnet error
104

Possible cause

Troubleshooting

Explanation

the expiration date. See License Files on page
8 for more information.

The network adaptor on the Minitab License
Manager server is disabled.

The network adaptor card must be enabled for
the Minitab License Manager server to verify
the MAC address. Without this, Minitab cannot
start. This issue is most commonly encountered
with laptop computers that may change the
status of a network card under various
conditions.

The license file was modified.

You can make a few valid changes to the license
file, such as specifying a port number. Most
other changes will corrupt the license file,
making it unusable to Minitab License Manager.

The date is incorrect on the computer that runs
Minitab License Manager software.

Minitab installations are sensitive to the
computer's date.

Minitab License Manager is installed to
C:\FlexLM\Minitab.

Minitab License Manager should not be
installed to this directory. Uninstall Minitab
License Manager and install to another
directory. See
www.minitab.comy/support/answers/answeraspx?id=2251
for more information.

The Minitab License Manager service is not
running on the license server.

The Minitab License Manager service must be
running to provide license requests for Minitab.

Minitab License Manager is using a different
communication port than expected.

Possible cause

Multiple FLEXIm license managers may be
running on this server, which caused the
Minitab License Manager to use a different port.
See To specify a license manager port on page
14 to manually configure ports.

Explanation

You attempt to borrow a license longer than is
allowed by either the expiration date in the
license file or a limit set in the options file.

You cannot borrow a license beyond the
expiration data of the license file. If the specified
end date for borrowing is before the expiration
date, the options file may contain limits on
borrowing. See Options file on page 15 for more
information.

Minitab License Manager fails to start

If the Minitab License Manager service fails to start, you may see the following error message:

The Minitab License Manager service on Local Computer started and then
stopped. Some services stop automatically if they have no work to do, for
example, the Performance Logs and Alerts Services.

Use the following table to troubleshoot the problem:
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Web site errors

Access Denied

Unable to
Proceed:
Entitlements
Not Available

Possible cause

Troubleshooting

Explanation

The license file (ninitab.1lic) is not in the
Minitab License Manager installation directory.

Minitab License Manager browses to
C:\Program Files\Minitab\License Manager
for the license file. Ensure that minitab.lic is at
this location.

The license file is not named correctly.

The license file must be named "minitab.lic"
(unless this default value was modified later).
Make sure that the file is not named
minitab.lic.txt (a common mistake). Confirm
that the file does not end with .txt. Right-click
the file, choose Properties, and verify that Type
of file is License and not Text Document.

Extra text is in the license file.

Some text editors, such as WordPad, may add
unwanted content to your file. See Sample
license file on page 8 for an example of a
license file with no unnecessary text. Open the
file in Notepad.

Minitab License Manager does not have
permission to write the log file (ninitab.d1)
to the directory specified in the Config Services
tab of LMTOOLS.

By default, Minitab License Manager creates
minitab.dl in C:\Program Files\Minitab\License
Manager. You can specify a different directory
with LMTOOLS (Imtools.exe). Make sure that
the account that runs the Minitab License
Manager service has write access to this
directory.

Minitab License Manager server has non-ANSI
characters in its name.

Web site errors

For best results, install Minitab License Manager
to a computer with only ANSI characters in its
name.

If you try to log in to the Minitab multi-user license management web pages and you are not
an authorized user, the Access Denied error message may appear. For more information, see
Step 1: Designate authorized users of multi-user licensing web pages on page 3.

If you log in to the multi-user license management web pages to create license files and there
are no valid orders for your organization, the message Unable to Proceed: Entitlements
Not Available appears. Contact your Minitab Sales Representative.

Online resources

The following online resources are available:

e Customer support questions in the Minitab Knowledgebase at

www.minitab.com/support/answers/

e The latest downloads for Minitab multi-user products at
http:/www.minitab.com/support/licensing/multi-user/downloads/default.aspx
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Online resources Troubleshooting

¢ The latest documentation for Minitab multi-user products at
http:/iwww.minitab.com/support/licensing/multi-user/documentation/default.aspx

¢ 'The FLEXnet Licensing End User Guide at
wwwimiritabeormiploadedtiles/Shared_ResourcesDocuments/License_Managementfiexet_licensing end user guidepdf
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